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ファイルが存在するのに「存在しない」とエラーになる場合の対処方法

ファイルが確かに存在しているにもかかわらず、おじどうさんのシナリオ実行時に「ファイルが存在しません」などのエラーが発生する場合があります。

この問題は、OneDriveやDropboxなどの「クラウドファイル同期プログラム」が原因となっていることがあります。

原因

OneDriveやDropboxなどのクラウドストレージでは、ファイルが「オンライン状態(実体がローカルに存在しない状態)」になっている場合があります。

このようなファイルは、エクスプローラー上では見えていても、おじどうさんからは実際に存在しない(未ダウンロード)ファイルとして扱われ、操作対象にできません。

対象となるクラウド同期サービス(例)

 ・OneDrive

 ・Dropbox

 ・Google Drive(ファイルストリーム機能)

 ・Box など

回避方法

以下のいずれかの方法をお試しください。

 ・方法① ファイルをクラウド同期フォルダ以外に移動する

  操作したいファイルを、ローカルのフォルダ(例:C:\Users\〇〇\Documents など)にコピーまたは移動してください。

 ・方法② ファイルを常にオフラインで使用できるように設定する(OneDriveの場合)

  1.対象ファイルまたはフォルダを右クリック
   →「常にこのデバイスに保持する」を選択

   2.実際にローカルにダウンロードされていることを確認する

   ※状態アイコンが「緑色のチェックマーク」になっている必要があります

補足

 ・クラウド同期対象のファイルは、ダウンロード待機中や一時的にアクセス不能になることがあり、自動処理に不向きです。

 ・RPAの安定稼働のためには、ファイルは必ずローカル環境上で扱うようにしてください。

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